Denegación de servicio a través de bzip2 en Sun Solaris.

SUNSe han encontrado dos fallos de seguridad en el comando bzip2 en Solaris 8, 9 y 10 que podrían permitir que un atacante eludiese restricciones de seguridad y causase una denegación de servicio.

* La primera vulnerabilidad en bzip2 podría permitir que un atacante local leyera o modificara archivos pertenecientes a otro usuario local que haga uso de bzip2, incluyendo archivos de sistema si bzip2 es llamado por un usuario con privilegios.

* La segunda vulnerabilidad en bzip2 podría permitir la creación de archivos demasiado largos al descomprimir archivos bzip2 especialmente modificados, lo que podría forzar el uso todo el espacio del disco, causando una denegación de servicio.

Según versión y plataforma, se recomienda instalar los siguientes parches:

Para plataforma Sparc:
Solaris 8 instalar parche 138441-01 o superior.
Solaris 9 instalar parche 114586-02 o superior.
Solaris 10 instalar parche 126868-01 o superior.

Para plataforma x86:
Solaris 8 instalar parche 138442-01 o superior.
Solaris 9 instalar parche 114587-02 o superior.
Solaris 10 instalar parche 126869-02 o superior.

Fuente: antivirusgratis.com.ar

 

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>